Kotlin1.4.0的候选版本发布了改进了对GradleKotlinDSL脚本的IDE支持

Kotlin 1.4.0 的候选版本发布了。

主要带来的新特性和改进有:

改进的 *.gradle.kts ​​​​​​​支持、加载脚本配置,和更好的错误报告

Kotlin 1.4.0-RC 中改进了对 Gradle Kotlin DSL 脚本(*.gradle.kts 文件)的 IDE 支持。

以前,在 build.gradle.kts 的 buildscript 或 plugins 块中添加新插件时,新脚本配置将自动在后台加载。为了提高性能,新版本删除了这种自动行为,即在键入时将更改应用于脚本配置。对于 Gradle 6.0 及更高版本,需要通过单击 “Load Gradle Changes” 或通过重新导入 Gradle 项目将更改应用到配置。

之前只能在单独的日志文件中看到 Gradle Daemon(后台运行的进程,该进程负责所有与 Gradle 相关的任务和活动)中的错误。现在,如果使用 Gradle 6.0 或更高版本,则 Gradle 守护程序将直接返回有关错误的所有信息,并将其显示在“构建”工具窗口中。这样既省时又省力。

对于多平台项目和面向单个平台的项目,所有源集现在默认都包括标准库依赖项

绝大多数项目都需要 Kotlin 标准库。从 1.4.0-RC 开始,不再需要在每个源集中手动声明对 stdlib 的依赖关系​​​​​​​,现在将默认添加它。自动添加的标准库版本将与 Kotlin Gradle 插件的版本相同。

简化对 CocoaPods 依赖项的管理

现在可以直接在 IntelliJ IDEA 中管理 Pod 依赖关系,同时享受它提供的好处,例如代码高亮和补全。还可以使用 Gradle 构建整个 Kotlin 项目,而无需切换到 Xcode。这意味着仅在需要编写 Swift/Objective-C 代码或在模拟器或设备上运行应用程序时,才需要使用 Xcode。现在,还可以使用本地存储的 Pod 库。

改进了 Kotlin/JS 集成,可在 Gradle 中实现 npm 依赖项、CSS 和 dukat 的集成,以及在默认编译器后端中使用 @JsExport 注释的功能

Kotlin 1.4.0-RC 使 @JsExport 注释与默认的编译器后端兼容。还提供了对 npm 依赖关系管理和 Gradle 项目的 Dukat 集成的更健壮和更细粒度的控制,进一步完善对 CSS 的支持,并首次展示与 Node.js API 的集成。

Node.js API 绑定的预览

此版本带来不少对 API 的改进和实验性 API。

Kotlin 1.4.0-RC 还具有调试协程和定义深层递归功能,官方表示将在接下来的几天单独发文介绍。

郑重声明:本文版权归原作者所有,转载文章仅为传播更多信息之目的,如作者信息标记有误,请第一时间联系我们修改或删除,多谢。